¡Bienvenido a Universo Maker!
¿Es esta la primera vez que visitas el foro? Si es así te recomendamos que te registres para tener completo acceso a todas las áreas y secciones del foro, así también podrás participar activamente en la comunidad. Si ya tienes una cuenta, conectate cuanto antes.
Iniciar Sesión Registrarme

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo Mensaje [Página 1 de 1.]

#1 Problemas con Sprites VE Animated Battle el Lun Mar 07, 2016 3:42 am

Radömizer

avatar
Tengo un pequeño gran problema con el Sistema de batalla de Victor Sant, el problema es bastante básico pero aún así no logro encontrar en el script cómo solventarlo.

El problema es que he creado mi battle personalizado pero el script no lo reconoce correctamente, en casi todas las animaciones recorta los sprites y en otras muestra la animación incorrecta, no logro encontrar en qué parte del script debo modificar el tamaño predeterminado o si él lo hace por si solo.

Battle Sprite:

Orden de los rows:
Código:
# Main Poses
 # name:   row,
idle:  1,   # Idle pose
guard: 2,   # Guard pose
evade: 2,   # Evade pose
danger: 3,   # Low HP pose
hurt:  4,   # Damage pose
attack: 5,   # Physical attack pose
use:   6,   # No type use pose
item:  6,   # Item use pose
skill: 7,   # Skill use pose
magic: 8,   # Magic use pose
advance:   9,   # Advance pose
retreat:   10,  # Retreat pose
escape: 10,  # Escape pose
victory:   11,  # Victory pose
intro: 12,  # Battle start pose
dead:  13,  # Incapacited pose
ready: nil, # Ready pose
itemcast:  nil, # Item cast pose
skillcast: nil, # Skill cast pose
magiccast: nil, # Magic cast pose
command:   nil, # Command pose
input: nil, # Input pose
cancel: nil, # Cancel pose

Script:

https://victorenginescripts.wordpress.com/rpg-maker-vx-ace/animated-battle/

https://drive.google.com/open?id=0B0cSp2lASM9wdjMwNEMtMFlkR1k

#2 Re: Problemas con Sprites VE Animated Battle el Lun Mar 07, 2016 4:05 am

Reputación del mensaje :100% (1 voto)

Tomate

avatar
Hm...por ahora te diré que si "recorta" tus battlers es porque, quizás, están mal "posicionados". Es decir, en la planilla debes asegurarte que cada chara individual ocupe el mismo tamaño siempre. Es decir, si son de 40x40 píxeles, todos deben tener el mismo tamaño cuando los juntas en el charset.

Con respecto a mostrar la animación equivocada, debe ser un tema más largo para solucionar, luego miraré el script e intentaré ayudarte. Ahora es tarde y debo irme a dormir. Ópalo Sonrisa Grande

¡A ver si alguien más conoce la solución! Ópalo Hachimaki



#3 Re: Problemas con Sprites VE Animated Battle el Lun Mar 07, 2016 4:40 am

Radömizer

avatar
@Tomate escribió:Hm...por ahora te diré que si "recorta" tus battlers es porque, quizás, están mal "posicionados". Es decir, en la planilla debes asegurarte que cada chara individual ocupe el mismo tamaño siempre. Es decir, si son de 40x40 píxeles, todos deben tener el mismo tamaño cuando los juntas en el charset.

Con respecto a mostrar la animación equivocada, debe ser un tema más largo para solucionar, luego miraré el script e intentaré ayudarte. Ahora es tarde y debo irme a dormir. Ópalo Sonrisa Grande

¡A ver si alguien más conoce la solución! Ópalo Hachimaki

Ya hice 3 battlers sprites de esos diferentes y ninguno funciona Ópalo Llanto

Ya me aseguré de que todos ocupan lo mismo, 5 frames de alto y 3 de ancho, en realidad es como si cuando el Pj va a atacar y salta hacia el enemigo el movimiento de parábola que describe es el mismo que se recorta mal en el el battler, es super extraño. creo que por lo mismo cuando escapa cambia al row incorrecto, por el movimiento que hace, creo que por ahí va la causa pero estoy cansado de revisar el script y de verdad no tengo ni idea Opalo Triste

Gracias tomate por responder todos los temas, de verdad se siente en el foro la amabilidad de la gente Ópalo Contento

#4 Re: Problemas con Sprites VE Animated Battle el Lun Mar 07, 2016 5:58 am

Reputación del mensaje :100% (1 voto)

Bleuw

avatar
Si no cambiaste la línea de rows y frames, tenés mal la plantilla.
tenés dos opciones, o modificar la plantilla a como viene por defecto de uso en el script o modificar el número del script.

Mirá

Eso quiere decir, 4 horizontal, 14 vertical. Vos estás usando una plantilla de 5 por 13 si no estoy contando mal, que es muy posible. Por lo que si ponés 5 en vez de 4 y 13 en vez de 14, debería funcionar tu plantilla tal cual está.

Espero te sirva.

Saludos y bienvenido.

#5 Re: Problemas con Sprites VE Animated Battle el Mar Mar 08, 2016 3:16 am

Radömizer

avatar
Creo que soy un poco tonto jejeje Ópalo Sonrisa Grande

Muchas gracias a ambos @Tomate y @Bleuw, había configurado bien los frames con 5, pero el row no, como el n° 14 no tiene nada asignado no me había percatado de que sobraba uno jajajaja

Problema resuelto, muchas gracias y Ópalo Reputación para ambos.

Saludos Ópalo Gato

Contenido patrocinado


Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.