¡Bienvenido a Universo Maker!
¿Es esta la primera vez que visitas el foro? Si es así te recomendamos que te registres para tener completo acceso a todas las áreas y secciones del foro, así también podrás participar activamente en la comunidad. Si ya tienes una cuenta, conectate cuanto antes.
Iniciar Sesión Registrarme

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo Mensaje [Página 1 de 1.]

#1 ayuda con LAG T_T el Lun Jul 06, 2015 6:49 pm

stiven202

avatar
Tengo un problema que me esta desesperando para RPG MAKER VX ACE

Tengo un evento en "inicio automatico" para una escena con pocos dialogos y este me causa lag, hace que el juego baje de los 60 FPS que va normalmente y lo peor, el lag nunca se quita, una vez iniciado ese evento sigue con lag eternamente, no importa lo que haga.

Deben saber varias cosas:

1. No tengo otros eventos en proceso paralelo ni en el mapa ni en eventos comunes.
2. He probado borrando el evento de inicio automatico y aun asi va con lag.

Este es el evento en cuestion...

link: http://illiweb.com/fa/pbucket.gif



Me parece muy raro que un solo evento en "Inicio automático" cause lag indefinidamente sabiendo que le asigno "2" a la variable para que pase a otra pagina en donde ya está en "proceso paralelo" y no hay nada de código ahí.

Ustedes diran: "y por qué no lo haces todo con proceso paralelo?" y yo les digo que lo quiero hacer con "inicio automático" porque de esta manera evito que el personaje pueda moverse mientras van apareciendo los diálogos.

Prácticamente esto haría inutilizable los eventos con detonate "inicio automático", si siempre van a causar lag.

¿me podrian ayudar con esto? que podria estar causando tanto lag? gracias.

#2 Re: ayuda con LAG T_T el Lun Jul 06, 2015 8:27 pm

Ledai

avatar
No sé como funciona el Ace, pero prueba a poner en la segunda pagina (ya que está vacía y no sirve de nada ) como evento normal y no en paralelo, si tienes eventos en paralelo estos se ejecutan constantemente vez tras vez, lo que pude causar bajadas de rendimiento... otra opción es ponerle un esperar 20 frames en su contenido a ver si se soluciona, pero es tontería pudiendo poner el evento como uno normal sin ejecutarse continuamente.




Entérate de todas las novedades

#3 Re: ayuda con LAG T_T el Mar Jul 07, 2015 5:04 pm

XSerozY

avatar
Ni idea cual sería el problema, prueba como dice Leda cambiar la segunda página para que inicie como evento normal, no como proceso paralelo.

Otra idea que te puedo dar es que pruebes un sistema anti lag, que es un script que te lo reduce considerablemente.

No se si se está permitido poner links a otras páginas en el foro, así que te recomiendo que busques en google el "Antilag de MogHunter para VXAce", es que yo uso, creo que lo puedes encontrar en su Master Demo.

Saludos!

Contenido patrocinado


Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.