¡Bienvenido a Universo Maker!
¿Es esta la primera vez que visitas el foro? Si es así te recomendamos que te registres para tener completo acceso a todas las áreas y secciones del foro, así también podrás participar activamente en la comunidad. Si ya tienes una cuenta, conectate cuanto antes.
Iniciar Sesión Registrarme

No estás conectado. Conéctate o registrate

Ver el tema anterior Ver el tema siguiente Ir abajo Mensaje [Página 1 de 1.]

#1 quitar efecto fade del scene intro ljury [xp] el Mar Mar 12, 2013 10:38 am

sombi02

avatar
saludos.

disculpen tengo una duda, es que me gustaria quitar el efecto de "fade" de este script, es quiero hacer una pequeña animacion antes del titulo, pero el efecto del fade hace que quede mal, aca esta el script que ando usando

Código:
#---------------------------------------------------------------------
  # Scene_Intro
  # Autor: Ljury
  # Version: 0.0.1
  #------INSTRUCCIONES--------------------------------------------------
  # 1.- Crear un nuevo script y pegar sobre main
  # 2.- En el script Main buscar $scene = Scene_Title.new y cambiar por
  # $scene = Scene_Intro.new
  # 3.- Las imagenes para la introduccion deben ir en la carpeta pictures
  # 4.- Configurar el script
  # 4.1 .- en la linea 25 se inicia la configuracion del script
  # 4.2 .- Alli, las configuraciones deben ir entre corchetes []
  # 4.3 .- en el interior de los corchetes debe ir primero el nombre de la
  # imagen, luego debe ir una coma, y la cantidad de tiempo que duraran los
  # efectos de "fade" (cuando entra la imagen), otra coma y el tiempo que
  # durara la imagen en si en pantalla. (se incluye un pequeño ejemplo de la
  # estructura)
  #---------------------------------------------------------------------

class Scene_Intro
 
  def initialize
    @config = [
    # nombre image    #fades #wait
    ["navyguild.png",  40 , 60  ],
    ["cellphone.png",  40 , 60  ],
    ]
   
    @sprite = Sprite.new
    @sprite.opacity = 0
    @scene = 0
    @counter = 0
    @sprite.bitmap = RPG::Cache.picture(@config[@scene][0].to_s)
   
  end
 
  def main
   

    Graphics.transition
    # Main loop
    loop do
      # Update game screen
      Graphics.update
      # Update input information
      Input.update
      # Frame update
      update
      # Abort loop if screen is changed
      if $scene != self
        break
      end
    end
    # Prepare for transition
    Graphics.freeze
    # Dispose of title graphic
    @sprite.bitmap.dispose
    @sprite.dispose
  end
   
  def update
     
    if ((@counter / (@config[@scene][1]) ).ceil) == 1
      @sprite.opacity += 255 / @config[@scene][1]
    elsif ((@counter /  (@config[@scene][1])).ceil) == 3
      @sprite.opacity -= 255 / @config[@scene][1] 
    end
   
    if @counter == ((@config[@scene][1])*4)
      @scene += 1
      @counter = 0
      if @config.size == @scene
        $scene = Scene_Title.new       
      else
        @sprite.bitmap = RPG::Cache.picture(@config[@scene][0].to_s)
      end
    end
    @counter += 1
  end
  end


si pudieran ayudarme se los agradeceria mucho, yo intente modificarlo pero no pude X_x

youkai

avatar
Pues para eso diria yo que tienes que cambiar:
Código:
 @config = [
    # nombre image    #fades #wait
    ["navyguild.png",  40 , 60  ],
    ["cellphone.png",  40 , 60  ]
    ]
por:
Código:
 @config = [
    # nombre image    #fades #wait
    ["navyguild.png",  0 , 60  ],
    ["cellphone.png",  0 , 60  ]
    ]
Segun el script ese numero es el encargado del fade. No he probado el script, asi que lo que digo lo saque de mirar el script por arribita xDD Si con 0 te diera error, pon 1.
Saludos,
¥oukai

sombi02

avatar
Bueno logre resolver el problema usando un video xD, mejor asi, si alguien puede con este detalle que lo ponga aun asi para los demas, saludos

----------------------------------------------------------------------------------------------------------------------

XD gracias por responder, pero eso que me comentas ya lo intente, al poner 0 me da error, y al poner 1 el fade es como un flash de pantalla, y en una animacion se ve feo sin contar q te fastidia los ojos, gracias aun asi

#4 Re: quitar efecto fade del scene intro ljury [xp] el Miér Mar 13, 2013 5:39 am

youkai

avatar
Y por que no pones lo que hiciste para resolverlo? Asi los demas pueden tambien aprender a solucionar ese problema XD Sin que tenga que venir yo y modificar el script...
Saludos,
¥oukai

sombi02

avatar
tecnicamente no lo resolvi, solo puse un script de video q encontre, creare un nuevo tema, poniendo el script

Contenido patrocinado


Ver el tema anterior Ver el tema siguiente Volver arriba  Mensaje [Página 1 de 1.]

Permisos de este foro:
No puedes responder a temas en este foro.